Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #4384 (closed)

Opened 13 years ago

Closed 13 years ago

BUG: test3138 - OmeroPy

Reported by: wmoore Owned by: cblackburn
Priority: major Milestone: OMERO-Beta4.3
Component: OmeroPy Version: n.a.
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2011-03-10 (7)

Description

Test turned off in [d6e5388fd743306c9f89066577452eac277459dd/ome.git]

======================================================================
FAIL: test3138 (__main__.TestTickets4000)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "test/integration/tickets4000.py", line 30, in test3138
    self.loginAttempt(name, 0.1, "GOOD", less=True)
  File "test/integration/tickets4000.py", line 48, in loginAttempt
    self.assertTrue(T < t, "%s > %s" % (T, t))
AssertionError: 0.11435508728 > 0.1

Change History (9)

comment:1 Changed 13 years ago by jmoore

  • Remaining Time set to 0.1

This is a performance test, and is just slightly over the limit. 0.11 > 0.1 We can easily change this, but we should put some more thought into how to set this value centrally. Perhaps it can be based on some metric against the server? Or if one test fails, then the others are skipped?

comment:2 Changed 13 years ago by jmoore <josh@…>

  • Remaining Time changed from 0.1 to 0
  • Resolution set to fixed
  • Status changed from new to closed

(In [fb41050de4c6aa8af9a8c2c9027d4674226005c3/ome.git] on branch develop) Forcing reload of user context in test (Fix #4384, See #4011)

comment:3 Changed 13 years ago by jmoore

  • Remaining Time changed from 0 to 0.25
  • Resolution fixed deleted
  • Status changed from closed to reopened

Previous commit was intended for #4383.

comment:4 Changed 13 years ago by jmoore

  • Owner jmoore deleted
  • Status changed from reopened to new

comment:5 Changed 13 years ago by jmoore <josh@…>

  • Remaining Time changed from 0.25 to 0
  • Resolution set to fixed
  • Status changed from new to closed

(In [8ad0c4de414ee5589601bf11746700cc9396e2f9/ome.git] on branch dev_4_2) Forcing reload of user context in test (Fix #4384, See #4011)

comment:6 Changed 13 years ago by jmoore

  • Remaining Time changed from 0 to 0.25
  • Resolution fixed deleted
  • Status changed from closed to reopened

This was a cherry-pick. Again, should not have been closed.

comment:7 Changed 13 years ago by jburel

  • Sprint changed from 2011-02-24 (6) to 2011-03-10 (7)

Moved from sprint 2011-02-24 (6)

comment:8 Changed 13 years ago by jburel

  • Owner set to cblackburn
  • Status changed from reopened to accepted

comment:9 Changed 13 years ago by cblackburn

  • Remaining Time changed from 0.25 to 0
  • Resolution set to duplicate
  • Status changed from accepted to closed

This task raises a bigger issue that that should be looked at under #4630

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.71567 sec.)

We're Hiring!