Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #477 (closed)

Opened 13 years ago

Closed 13 years ago

New CategoryGroups are not visible in Shoola client

Reported by: jrswedlow Owned by: jburel
Priority: critical Cc: jburel
Sprint: n.a.
Total Remaining Time: n.a.

Description

In Shoola, a new CategoryGroup? can not be used, since it is not visible in any of the Category workflows.

Change History (5)

comment:1 Changed 13 years ago by jburel

  • Keywords set to iteration#6

comment:2 Changed 13 years ago by jrswedlow

new Nov 6 version gives exception when user tries to Classify Image from Projects display:

Abnormal termination due to an uncaught exception.
java.lang.IllegalStateException?: This method should only be invoked in the READY or NEW state.

at org.openmicroscopy.shoola.agents.treeviewer.view.TreeViewerComponent?.showClassifier(TreeViewerComponent?.java:408)
at org.openmicroscopy.shoola.agents.treeviewer.cmd.ClassifyCmd?.execute(ClassifyCmd?.java:117)
at org.openmicroscopy.shoola.agents.treeviewer.actions.ClassifyAction?.actionPerformed(ClassifyAction?.java:148)
at javax.swing.AbstractButton?.fireActionPerformed(AbstractButton?.java:1882)
at javax.swing.AbstractButton?$Handler.actionPerformed(AbstractButton?.java:2202)
at javax.swing.DefaultButtonModel?.fireActionPerformed(DefaultButtonModel?.java:420)
at javax.swing.DefaultButtonModel?.setPressed(DefaultButtonModel?.java:258)
at javax.swing.AbstractButton?.doClick(AbstractButton?.java:334)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1000)
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1041)
at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:231)
at java.awt.Component.processMouseEvent(Component.java:5554)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3126)
at java.awt.Component.processEvent(Component.java:5319)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4021)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3869)
at java.awt.LightweightDispatcher?.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher?.processMouseEvent(Container.java:3936)
at java.awt.LightweightDispatcher?.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1774)
at java.awt.Component.dispatchEvent(Component.java:3869)
at java.awt.EventQueue?.dispatchEvent(EventQueue?.java:463)
at java.awt.EventDispatchThread?.pumpOneEventForHierarchy(EventDispatchThread?.java:269)
at java.awt.EventDispatchThread?.pumpEventsForHierarchy(EventDispatchThread?.java:190)
at java.awt.EventDispatchThread?.pumpEvents(EventDispatchThread?.java:184)
at java.awt.EventDispatchThread?.pumpEvents(EventDispatchThread?.java:176)
at java.awt.EventDispatchThread?.run(EventDispatchThread?.java:110)

Exception in thread "AWT-EventQueue?-0"

comment:3 Changed 13 years ago by jburel

  • Keywords changed from iteration#6 to iteration6

comment:4 Changed 13 years ago by jburel

I see what the problem is.
I never had the problem b/c retrieval of thumbnail/annotations for an image is quite fast
so i was never in an "illegal" state.
I will check and see the implications of removing that controls

comment:5 Changed 13 years ago by jburel

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.155984 sec.)

We're Hiring!