Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #5632 (closed)

Opened 9 years ago

Closed 7 years ago

Add ArrayColumn type(s)

Reported by: jamoore Owned by: spli
Priority: critical Milestone: OMERO-4.4.7
Component: Services Version: n.a.
Keywords: n.a. Cc: analysis@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2012-12-18 (3)

Description

To support 2D matrices, array column type of each of the primitive types should be supported.

Well, part of the problem is that each row, a column in your rotated
scheme, correspond to the genotyping of a specific sample, and it is
what you keep accumulating (e.g., we have about 10k of them and more
will come). Thus, while N, the number of SNPs is fixed by the specific
technology, the number of records keeps increasing.
A possible alternative is to do some fromstring/tostring magic.
We will probably try that as a temporary solution.
It would be nice if we could have direct numpy array columns a la
pytable, however, because then it would be possible to explicitly do
column selections server side.

--gianluigi

Change History (10)

comment:1 Changed 8 years ago by jmoore

  • Cc hic@… added; szwells removed
  • Component changed from General to Services
  • Milestone changed from Unscheduled to OMERO-Beta4.4

Should evaluate this for 4.4.

comment:2 Changed 8 years ago by jmoore

  • Owner set to jmoore

comment:3 Changed 7 years ago by jmoore

  • Priority changed from minor to major

Unlikely to go into 4.4.0 but since it's an API change might be good to at least evaluate having it in the build.

comment:4 Changed 7 years ago by jmoore

  • Milestone changed from OMERO-Beta4.4 to OMERO-Beta4.4.1
  • Priority changed from major to critical

This will likely need to be done in a side-branch. Pushing.

comment:5 Changed 7 years ago by jmoore

  • Cc hic@… removed
  • Milestone changed from OMERO-4.4.4 to OMERO-4.5

This won't be happening for 4.4.4. Still critical.

comment:6 Changed 7 years ago by spli

  • Cc analysis@… added
  • Owner changed from jmoore to spli

comment:7 Changed 7 years ago by spli

  • Remaining Time set to 4
  • Status changed from new to accepted

comment:8 Changed 7 years ago by spli

Added to dev_4_4 in PR 538

comment:9 Changed 7 years ago by spli

  • Sprint set to 2012-12-18 (3)

comment:10 Changed 7 years ago by spli

  • Remaining Time changed from 4 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed

Implemented in https://github.com/openmicroscopy/openmicroscopy/pull/538

The query/selection API is in a separate ticket #10034

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.264463 sec.)

We're Hiring!