Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #5982 (closed)

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

Bug: JAI ImageIO fork is missing files from JAR

Reported by: cxallan Owned by: cxallan
Priority: blocker Milestone: OMERO-Beta4.3.1
Component: Bio-Formats Version: n.a.
Keywords: n.a. Cc: mlinkert
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2011-07-07 (1)

Description

Missing localized strings which are located in properties files are missing from Bio-Formats JARs.

Change History (8)

comment:1 Changed 13 years ago by cxallan

  • Owner changed from mlinkert-x to cxallan
  • Status changed from new to accepted

Example exception as seen from failed BIOFORMATS-trunk builds:

java.lang.RuntimeException: java.lang.NullPointerException
	at com.sun.media.imageioimpl.common.I18NImpl.getString(I18NImpl.java:75)
	at com.sun.media.imageioimpl.plugins.jpeg2000.I18N.getString(I18N.java:51)
	at com.sun.media.imageioimpl.plugins.jpeg2000.J2KImageWriter.checkSampleModel(J2KImageWriter.java:510)
	at com.sun.media.imageioimpl.plugins.jpeg2000.J2KImageWriter.write(J2KImageWriter.java:232)
	at loci.formats.services.JAIIIOServiceImpl.writeImage(JAIIIOServiceImpl.java:119)
	at loci.formats.utests.JAIIIOServiceTest.testWriteFloatingPointLossy(JAIIIOServiceTest.java:292)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at org.testng.internal.MethodHelper.invokeMethod(MethodHelper.java:644)
	at org.testng.internal.Invoker.invokeMethod(Invoker.java:546)
	at org.testng.internal.Invoker.invokeTestMethod(Invoker.java:700)
	at org.testng.internal.Invoker.invokeTestMethods(Invoker.java:1002)
	at org.testng.internal.TestMethodWorker.invokeTestMethods(TestMethodWorker.java:137)
	at org.testng.internal.TestMethodWorker.run(TestMethodWorker.java:121)
	at org.testng.TestRunner.runWorkers(TestRunner.java:908)
	at org.testng.TestRunner.privateRun(TestRunner.java:617)
	at org.testng.TestRunner.run(TestRunner.java:498)
	at org.testng.SuiteRunner.runTest(SuiteRunner.java:329)
	at org.testng.SuiteRunner.runSequentially(SuiteRunner.java:324)
	at org.testng.SuiteRunner.privateRun(SuiteRunner.java:296)
	at org.testng.SuiteRunner.run(SuiteRunner.java:201)
	at org.testng.TestNG.createAndRunSuiteRunners(TestNG.java:915)
	at org.testng.TestNG.runSuitesLocally(TestNG.java:879)
	at org.testng.TestNG.run(TestNG.java:787)
	at org.testng.TestNG.privateMain(TestNG.java:952)
	at org.testng.TestNG.main(TestNG.java:925)
Caused by: java.lang.NullPointerException
	at java.util.Properties$LineReader.readLine(Properties.java:418)
	at java.util.Properties.load0(Properties.java:337)
	at java.util.Properties.load(Properties.java:325)
	at java.util.PropertyResourceBundle.<init>(PropertyResourceBundle.java:111)
	at com.sun.media.imageioimpl.common.I18NImpl.getString(I18NImpl.java:73)
	... 27 more

comment:2 Changed 13 years ago by Chris Allan <callan@…>

(In [e37c6c33a55554b5e26fbf75d2ac537bcd22cb24/bioformats.git]) Ensure properties files are available in JARs. (See #5982)

comment:3 Changed 13 years ago by Chris Allan <callan@…>

(In [bb186b542c2ac97ad5eb1a636c6d7a99165e7416/bioformats.git]) Ensure properties files are available in JARs. (See #5982)
(cherry picked from commit e37c6c33a55554b5e26fbf75d2ac537bcd22cb24)

comment:4 Changed 13 years ago by cxallan

  • Remaining Time changed from 0.25 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed

comment:5 Changed 13 years ago by Chris Allan <callan@…>

(In [e37c6c33a55554b5e26fbf75d2ac537bcd22cb24/bioformats.git]) Ensure properties files are available in JARs. (See #5982)

comment:6 Changed 13 years ago by Chris Allan <callan@…>

(In [bb186b542c2ac97ad5eb1a636c6d7a99165e7416/bioformats.git]) Ensure properties files are available in JARs. (See #5982)
(cherry picked from commit e37c6c33a55554b5e26fbf75d2ac537bcd22cb24)

comment:7 Changed 13 years ago by Chris Allan <callan@…>

(In [e37c6c33a55554b5e26fbf75d2ac537bcd22cb24/bioformats.git]) Ensure properties files are available in JARs. (See #5982)

comment:8 Changed 13 years ago by Chris Allan <callan@…>

(In [e37c6c33a55554b5e26fbf75d2ac537bcd22cb24/bioformats.git]) Ensure properties files are available in JARs. (See #5982)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.68655 sec.)

We're Hiring!