Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #5984 (closed)

Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

Bug: insight does not check version is 4.3+

Reported by: jamoore Owned by: jburel
Priority: critical Milestone: OMERO-Beta4.3.1
Component: Insight Version: n.a.
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2011-07-07 (1)

Description

While testing #4910, I logged into to a 4.2.2 server with insight, tried to open a project and received:

java.lang.Exception: org.openmicroscopy.shoola.env.data.DSAccessException: Cannot access data. 
Cannot load hierarchy for class pojos.DatasetData.
...
Caused by: Ice.MarshalException
    reason = (null)
	at IceInternal.BasicStream.typeToClass(BasicStream.java:2403)

Change History (5)

comment:1 Changed 13 years ago by jmoore

Jean-Marie, I assume that any fix you put in place will also fix importer which also fails with a marshal exception. If not, we should probably open another ticket.

comment:2 Changed 13 years ago by jburel

  • Remaining Time set to 0.15
  • Status changed from new to accepted

review code and improve workflow

comment:3 Changed 13 years ago by jburel <j.burel@…>

  • Remaining Time changed from 0.15 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed

(In [d9be5e7cfdaa0e50de46028c746453e729dbd7bc/ome.git] on branch develop) Check compatibility between client and server (close #5984).

comment:4 Changed 13 years ago by jburel <j.burel@…>

(In [e6f8a3ccf999b67af179bbfce93441962bae6102/ome.git] on branch develop) Improve code to check client-server compatibility (see #5984)

comment:5 Changed 13 years ago by jburel <j.burel@…>

(In [5fbea51a41f223d2856767317695074126b3e474/ome.git] on branch develop) Review retrieval of server version (see #5984)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.67368 sec.)

We're Hiring!