Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #6166 (closed)

Opened 8 years ago

Closed 7 years ago

Educational use of OMERO

Reported by: saloynton Owned by: saloynton
Priority: major Milestone: OMERO-4.4
Component: General Keywords: n.a.
Cc: jburel, cxallan, jrswedlow, atarkowska, rkferguson, eehill Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: 0.0d Estimated Remaining Time: n.a.

Description (last modified by saloynton)

The following documents the requirements for OMERO being used in the histology and neuroanatomy department in Dundee the request to use OMERO for teaching purposes.

Initial Background information

The background information gathered after the initial discussion for the use of OMERO in the histology and neuroanatomy department in Dundee and his request to use OMERO for teaching purposes.

The initial starting points for the requirements:

  • The starting amount of students who would be using the system would be 50-60 approximately. (This would not be all at once)
    • The amount of students that could go on to the use the system could go up to approximately 300 students. This would cover the departments of dental, medics and forensic anthropology.
  • There are 50 .svs images required for the entire year to be stored. This could be further refined by making sets of images available each term.
  • There are additional images scanned that would be made available for student use where necessary, such as post grad students.
  • The students would have to be restricted to read only access to the image.
    • To begin a single account is to be used for the initial set of students.
  • There is a requirement for the lecturer to be able to set questions about the images.
  • They would like to provide the students with the ability to view his annotations on an image and ultimately to allow the students to draw basic ROI's on the images. From the discussion this does not require any actual analysis but only the ability to view the shapes on the image.
    • The first stage of this has been set to allow the ROI's on big images and make them readable

The initial starting points for the requirements:

  • The starting amount of students who would be using the system would be 50-60 approximately. (This would not be all at once)
  • The amount of students that could go on to the use the system could go up to roughly 300 students. This would cover the departments of dental, medics and forensic anthropology.
  • There are 50 .svs images required for the entire year to be stored. This could be further refined by making sets of images available each term.
  • The students would have to be restricted to read only access to the image.
  • There is a requirement for the lecturer to be able to set questions about the images.
  • They would like to provide the students with the ability to view the annotations made by the lecturer on an image. From the discussion, this does not require any actual analysis but only the ability to view the shapes on the image.
  • The first stage of this has been set to allow the ROI's on big images and make them readable

A further meeting took place on 15/09/11 to confirm the core set of requirements over the following weeks.

The first teaching group starts the week beginning the 19/09/11 and runs until Christmas because of this the aim is to expose OMERO in phases as the development work through the term. The requirements have been broken up into two phases of work.

  • The first phase of work is to provide the lecturer and students with an early experience of what to expect and provide us with any preliminary feedback.
  • The second phase of work has been created to allow for the team to deal with the issue of the svs file and the additional time this will take. This can then be rolled out when ready and tested before handing over.

The following setup was agreed for the accounts.

  • The server shall be based in Dundee and managed by us for the early phase of work.
  • Students provided with local accounts [ldap login - if feasible]
  • A smaller set of 15 images will be used to begin with.

Phase I requirements

  • The ability to view ROI's on big images in the web client.

See ticket #6578


Actions

  • The confirmation of the local server that will be used and the necessary setup for this.
  • Pre-setup and testing for the accounts.
  • Training and a demonstration and set up for the necessary teaching groups required by the lecturer.
  • Suitable training for the students.

The target date for this is the 2nd week of October. [To be confirmed]

Phase II requirements

  • The ability to view the full set of svs image's

Actions.

A realistic timeframe for the necessary changes will need to be determined for the development process.

See ticket #6755

Attachments (9)

big-image-rois.png (1.8 MB) - added by jburel 8 years ago.
FirefoxScreenSnapz002.png (891.5 KB) - added by cxallan 8 years ago.
Label selection location issues
FirefoxScreenSnapz003.png (139.0 KB) - added by cxallan 8 years ago.
Additional screenshot of Text/Label? selection issues on a non-zoomed image
OMERO.insightScreenSnapz001.png (140.1 KB) - added by cxallan 8 years ago.
The same image with the solo Text/Label? ROI
SelectionBug.png (270.1 KB) - added by cxallan 8 years ago.
Tree selection bug
PartialLoadBug.png (95.5 KB) - added by cxallan 8 years ago.
Bug where a largish Image is partially loaded
PartialLoadBugZoomed.png (176.5 KB) - added by cxallan 8 years ago.
Bug where a largish Image is partially loaded, even when zoomed
big_image_rois3.png (1.4 MB) - added by wmoore 8 years ago.
Icons, scrollable table, long text display, toggle text, toggle previews etc.
big-image-rois3-insight.png (1.3 MB) - added by wmoore 8 years ago.
Same ROIs in Insight (no text wrapping).

Change History (27)

comment:1 Changed 8 years ago by saloynton

  • Description modified (diff)

comment:2 Changed 8 years ago by saloynton

  • Description modified (diff)

comment:3 Changed 8 years ago by agilo

  • Status changed from new to accepted

Updated status, related task in progress

comment:4 Changed 8 years ago by saloynton

  • Description modified (diff)

comment:5 Changed 8 years ago by saloynton

  • Description modified (diff)

comment:6 Changed 8 years ago by saloynton

Jean-Marie can I ask you could confirm the changes made for the requirements for the next two phases of work.

comment:7 Changed 8 years ago by saloynton

  • Milestone changed from OMERO-Beta4.3.2 to OME-5.0

comment:8 Changed 8 years ago by saloynton

The initial set of svs images for the first phase can now be found on squig under
data_repo/Scotts User Images/ Teaching svs images/Beta set

comment:9 Changed 8 years ago by saloynton

Phase I requirements - Pending
I have emailed the lecturer in order to keep him updated of the ongoing work for the ROI viewing of big images against the ongoing work for are own current release. I haven spoken with Ola and Will with regards to the requirements for the image viewer from ticket #6827. These changes shall be considered once the ROI web viewer
has been implemented.

Changed 8 years ago by jburel

Changed 8 years ago by cxallan

Label selection location issues

Changed 8 years ago by cxallan

Additional screenshot of Text/Label? selection issues on a non-zoomed image

Changed 8 years ago by cxallan

The same image with the solo Text/Label? ROI

Changed 8 years ago by cxallan

Tree selection bug

Changed 8 years ago by cxallan

Bug where a largish Image is partially loaded

Changed 8 years ago by cxallan

Bug where a largish Image is partially loaded, even when zoomed

comment:11 Changed 8 years ago by saloynton

  • Description modified (diff)

Changed 8 years ago by wmoore

Icons, scrollable table, long text display, toggle text, toggle previews etc.

Changed 8 years ago by wmoore

Same ROIs in Insight (no text wrapping).

comment:12 Changed 8 years ago by Will Moore <will@…>

(In [a3c4b0ee5bc5a87fa90a76818549d236013e09d4/ome.git]) Web roi thumbnails handle regions outside image. See #6166

comment:13 Changed 8 years ago by saloynton

Waiting on confirmation for a meeting to determine the wider feedback.

comment:14 Changed 8 years ago by saloynton

Meeting confirmed for Monday 19th December

comment:15 Changed 8 years ago by wmoore

Here's a summary of what we discussed on Monday 19th December (current status of things)...

Client functionality:
The only major issue with the clients is a bug with switching to view someone else's data in web.
http://trac.openmicroscopy.org.uk/ome/ticket/7692
I'll have a look at this, but it might be something that Ola has a better feel for.
Adding ROIs in Insight and viewing ROIs on big images in web seems to be working fine.
One possible improvement in web would be to include the current location of the viewport in the copy/paste link, allowing users to bookmark or e-mail a location. Currently we get x=0 and y=0.

Permissions, Groups etc.
After a bit of discussion, we concluded that there isn't a problem with allowing all users to see all images (with possible exception of sample images for exam questions etc).
Therefore, we can use Projects and Datasets to handle all image organisation, and students can simply be told where to look for particular images.
This solves any problems of moving images between groups, duplicating images etc.

This means that all images are in a single group.

Creating Accounts,
According to Chris (after discussion with Jonathan), there shouldn't be a problem with using Uni of Dundee LDAP (don't need to use Lifesci).
Central computing should already have LDAP groups that correspond to the various courses we're interested in. If not, these can be created - Just need to let them have list of names, e-mails? etc.
Then we should be able to configure things in OMERO to allow these accounts to log in, and put these users in a group.

Still undecided whether we want users on different courses to be in different groups (by default).
Assuming all the data is in a 'common' group, then each user would be in a 'course' group E.g. BSc_2012, as well as the 'common' group.
Although we don't have any particular need for 'course' groups at the moment, it's likely that they could be useful for some purposes at some stage?

Storage space.
It seems that currently we have 4 slides in Paul's account on gretzky.
However, the "disk space" utility in web doesn't take into account the compression for big images, so it very much over-estimates the disk usage.
Need to have a look at the size of pixel pyramids on disk. In due course, server needs to look at the file size (via FS lite or RawPixelsStore? etc).
Paul's 50 svs slides that account for 90% of his teaching take up 18GB. The full set (243 slides) takes up 41GB.
Typically, import of svs creates a series of images. We only need the largest image in each case. The others can (always)? be deleted.

Max Size Bug.
The Max-Size Bug is an issue bug not a blocker. http://trac.openmicroscopy.org.uk/ome/ticket/6967
Means the larger slides cannot be viewed at full resolution.
This work is largely done, but is not ready to be merged yet (needs testing, tests rewritten etc). Need to build a separate branch or cherry-pick to create a branch we can build etc.

UPDATE:
These are the only big images now under Paul's account (pfelts) on gretzky, with an extra column for size of pyramid on disk:

omero=# select id,image,sizeX,sizeY,pixelsType from pixels where image in (30062,30055,30056,30048,30050,30067,30072);

   id   | image | sizex | sizey | pixelstype    Disk space
 -------+-------+-------+-------+------------
  29848 | 30048 | 63385 | 51345 |       uint8    2.4G
  29850 | 30050 | 15846 | 12836 |       uint8    209M
  29855 | 30055 | 48979 | 64574 |       uint8    2.3G
  29856 | 30056 | 12244 | 16143 |       uint8    183M
  29862 | 30062 | 10564 |  9682 |       uint8    81M
  29872 | 30072 | 23769 | 19548 |       uint8    610M
  29867 | 30067 | 95078 | 78192 |       uint8    6.8G

Total disk space is about 12.5 GB (not the 74 GB reported in webadmin).
This is for 4 out of 50 slides. (The 4 largest in the list above are the highest resolution for each slide - extra ones are lower resolution copies).

Approx extrapolation to 50 slides would require 156 GB or 760 GB for 243 slides.
NB: This could vary a large amount depending on size of slides!

comment:16 Changed 7 years ago by rkferguson

  • Cc rkferguson eehill added

comment:17 Changed 7 years ago by saloynton

This user story is to be closed at the end of 4.4. release any additional support for the setup should use ticket #9307. The additional RFE's have gone into #7917 and #6264.

comment:18 Changed 7 years ago by saloynton

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.320287 sec.)

We're Hiring!