Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

User Story #7076 (closed)

Opened 8 years ago

Closed 6 years ago

Bio-Formats SCIFIO refactoring

Reported by: crueden-x Owned by: mhiner-x
Priority: major Milestone: Unscheduled
Component: Bio-Formats Keywords: n.a.
Cc: jrswedlow, cxallan, mlinkert, jburel, jamoore Story Points: n.a.
Sprint: n.a. Importance: n.a.
Total Remaining Time: n.a. Estimated Remaining Time: n.a.

Description (last modified by mhiner-x)

To facilitate better modularity and code reuse across a wide variety of use cases, we have begun work on a refactoring of Bio-Formats called SCIFIO: SCientific Image Format Input/Output?.

Bio-Formats has historically been targeted at the life sciences, and light microscopy especially, but SCIFIO aims to be a cross-discipline scientific imaging format library.

"Initial version of the split is available in the scifio branch of bio-formats.git. [Oct 2011] The "scifio" component will be permissively licensed and provide the core I/O infrastructure, while the "bio-formats" component provides the proprietary file format (PFF) readers and is GPL-licensed."

See also:

  • imagej:#100 - Bio-Formats core library split
  • More tickets to be filed soon

Change History (8)

comment:1 Changed 8 years ago by crueden-x

  • Description modified (diff)

comment:2 Changed 8 years ago by crueden-x

  • Description modified (diff)

comment:3 Changed 8 years ago by jrswedlow

  • Cc jrswedlow callan mlinkert-x added
  • Description modified (diff)

comment:4 Changed 8 years ago by mlinkert

  • Cc cxallan added; callan removed

comment:5 Changed 8 years ago by jmoore

  • Cc jburel jmoore added

comment:6 Changed 8 years ago by crueden-x

  • Owner changed from crueden-x to mhiner-x

comment:7 Changed 8 years ago by mhiner-x

  • Description modified (diff)
  • Status changed from new to accepted

Added link to ImageJ trac

comment:8 Changed 6 years ago by mhiner-x

  • Resolution set to duplicate
  • Status changed from accepted to closed

Closed as a duplicate of #7690

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.121672 sec.)

We're Hiring!