Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #8788 (closed)

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

Bug: Shift key in basket, hostory and search

Reported by: bpindelski Owned by: wmoore
Priority: blocker Milestone: OMERO-4.4
Component: Web Version: n.a.
Keywords: testing,phase1 Cc: web-team@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-07-03 (18)

Description (last modified by bpindelski)

When managing the contents of the basket, the images can be multi-selected only with the Command (Mac) / Ctrl (Windows) key held down. Shift doesn't work only, so the user can't select all images in one click.
When managing the contents of the history or search, the images cannot be multi-selected at all.

That breaks the user experience inside the data explorer.

Change History (17)

comment:1 Changed 10 years ago by atarkowska

  • Cc web-team@… added
  • Owner changed from web-team@… to atarkowska

comment:2 Changed 10 years ago by atarkowska

  • Priority changed from critical to minor

comment:3 Changed 10 years ago by atarkowska

  • Keywords testing phase1 added

comment:4 Changed 10 years ago by jburel

  • Sprint changed from 2012-05-22 (15) to 2012-06-05 (16)

Moved from sprint 2012-05-22 (15)

comment:5 Changed 9 years ago by jburel

  • Sprint changed from 2012-06-05 (16) to 2012-06-19 (17)

Moved from sprint 2012-06-05 (16)

comment:6 Changed 9 years ago by atarkowska

  • Description modified (diff)
  • Summary changed from Bug: Shift key in basket to Bug: Shift key in basket, hostory and search

comment:7 Changed 9 years ago by atarkowska

related problem #8788. This require more investigation.

comment:8 Changed 9 years ago by jburel

  • Sprint changed from 2012-06-19 (17) to 2012-07-03 (18)

Moved from sprint 2012-06-19 (17)

comment:9 Changed 9 years ago by atarkowska

  • Priority changed from minor to blocker

comment:10 Changed 9 years ago by cxallan

Example URL that is generated when being a bit too quick on the draw on the History page:

...
2012-06-27 11:10:54,417 WARNI [                 omeroweb.feedback.views] (proc.29152) handler404:161 Not Found: /webclient/metadata_details/dataset=7/undefined/
...

comment:11 Changed 9 years ago by wmoore

  • Owner changed from atarkowska to wmoore

comment:12 Changed 9 years ago by wmoore

The 404 reported by Chris above should be fixed by https://github.com/aleksandra-tarkowska/openmicroscopy/commit/23f8c6cc4a7b5ad08046fc66c28d108d833ea963
It was caused by drag selection of a single item.

comment:13 Changed 9 years ago by wmoore

https://github.com/aleksandra-tarkowska/openmicroscopy/commit/7e3658871adee688f795fd50402c4fef2dede9b4 fixes Shift-click selection in history and search tables (forgot basket)!

comment:14 Changed 9 years ago by wmoore

  • Resolution set to fixed
  • Status changed from new to closed

comment:15 Changed 9 years ago by bpindelski

It is consistent now in a way that holding down Shift works (i.e. a group of elements is selected). The only comment I'd add is that there is still and ambiguous behavior between the data explorer and other places mentioned in the bug (history, basket, search). In the data explorer the selection works as in the operating system (Shift + click selects all elements, Ctrl/Cmd? allows for picking which elements to select). In the history, basket and search - the Ctrl (Windows) and Cmd (Mac) doesn't work as in the operating system.

comment:16 Changed 9 years ago by bpindelski

  • Description modified (diff)

comment:17 Changed 9 years ago by wmoore

Ctrl-click is now supported - Also lots of cleanup of the selection code for basket, history and search: https://github.com/aleksandra-tarkowska/openmicroscopy/commit/cfe743050648055512db2af894459c54e783746c

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.67000 sec.)

We're Hiring!