Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Bug #883 (closed)

Opened 14 years ago

Closed 13 years ago

Exception thrown on StatefulServiceInterface.close()

Reported by: jamoore Owned by: jamoore
Priority: major Cc: jburel, cxallan, atarkowska
Sprint: n.a.
Total Remaining Time: n.a.

Description

An exception is thrown server-side and shows up in the server logs, when close() is called on a stateful service.

TransactionSynchronization.afterCompletion threw exception
org.hibernate.SessionException: Session is closed!
        at org.hibernate.impl.AbstractSessionImpl.errorIfClosed(AbstractSessionImpl.java:49)
        at org.hibernate.impl.SessionImpl.disconnect(SessionImpl.java:373)
        at org.springframework.orm.hibernate3.SpringSessionSynchronization.afterCompletion(SpringSessionSynchronization.java:228)
        at org.springframework.transaction.support.TransactionSynchronizationUtils.invokeAfterCompletion(TransactionSynchronizationUtils.java:133)
        at org.springframework.transaction.support.AbstractPlatformTransactionManager.invokeAfterCompletion(AbstractPlatformTransactionManager.java:904)
        at org.springframework.transaction.support.AbstractPlatformTransactionManager.triggerAfterCompletion(AbstractPlatformTransactionManager.java:879)
        at org.springframework.transaction.support.AbstractPlatformTransactionManager.processCommit(AbstractPlatformTransactionManager.java:707)
        at org.springframework.transaction.support.AbstractPlatformTransactionManager.commit(AbstractPlatformTransactionManager.java:632)
        at org.springframework.transaction.interceptor.TransactionAspectSupport.commitTransactionAfterReturning(TransactionAspectSupport.java:319)
        at org.springframework.transaction.interceptor.TransactionInterceptor.invoke(TransactionInterceptor.java:116)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
        at ome.tools.hibernate.ProxyCleanupFilter$Interceptor.invoke(ProxyCleanupFilter.java:169)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
        at ome.services.util.ServiceHandler.invoke(ServiceHandler.java:92)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
        at org.springframework.aop.interceptor.AbstractTraceInterceptor.invoke(AbstractTraceInterceptor.java:113)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
        at ome.security.basic.BasicSecurityWiring.invoke(BasicSecurityWiring.java:79)
        at org.springframework.aop.framework.ReflectiveMethodInvocation.proceed(ReflectiveMethodInvocation.java:171)
        at ome.services.util.OmeroAroundInvoke.call(OmeroAroundInvoke.java:161)
        at ome.services.util.OmeroAroundInvoke.loginAndSpringWrap(OmeroAroundInvoke.java:134)
        at sun.reflect.GeneratedMethodAccessor316.invoke(Unknown Source)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:585)
        at org.jboss.ejb3.interceptor.InvocationContextImpl.proceed(InvocationContextImpl.java:118)
        at org.jboss.ejb3.interceptor.EJB3InterceptorsInterceptor.invoke(EJB3InterceptorsInterceptor.java:63)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.entity.ExtendedPersistenceContextPropagationInterceptor.invoke(ExtendedPersistenceContextPropagationInterceptor.java:57)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.entity.TransactionScopedEntityManagerInterceptor.invoke(TransactionScopedEntityManagerInterceptor.java:54)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.AllowedOperationsInterceptor.invoke(AllowedOperationsInterceptor.java:47)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.tx.BMTInterceptor.handleStateful(BMTInterceptor.java:106)
        at org.jboss.ejb3.tx.BMTInterceptor.invoke(BMTInterceptor.java:132)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.aspects.tx.TxPropagationInterceptor.invoke(TxPropagationInterceptor.java:76)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.stateful.StatefulInstanceInterceptor.invoke(StatefulInstanceInterceptor.java:83)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.stateful.StatefulRemoveInterceptor.invoke(StatefulRemoveInterceptor.java:97)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.aspects.security.AuthenticationInterceptor.invoke(AuthenticationInterceptor.java:77)
        at org.jboss.ejb3.security.Ejb3AuthenticationInterceptor.invoke(Ejb3AuthenticationInterceptor.java:106)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.ENCPropagationInterceptor.invoke(ENCPropagationInterceptor.java:46)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.asynchronous.AsynchronousInterceptor.invoke(AsynchronousInterceptor.java:106)
        at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:101)
        at org.jboss.ejb3.stateful.StatefulContainer.dynamicInvoke(StatefulContainer.java:333)
        at org.jboss.aop.Dispatcher.invoke(Dispatcher.java:106)
        at org.jboss.aspects.remoting.AOPRemotingInvocationHandler.invoke(AOPRemotingInvocationHandler.java:82)
        at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:734)
        at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:560)
        at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:369)
        at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:165)

Change History (5)

comment:1 Changed 14 years ago by jmoore

  • Cc jburel callan added

comment:2 Changed 13 years ago by jmoore

  • Cc atarkowska added
From: Aleksandra Tarkowska <aleksandrat@lifesci.dundee.ac.uk>
To: Josh Moore <josh.moore@gmx.de>
Subject: ome.conditions.RemovedSessionExceptio

2008/04/30 08:25 +0100 [-] [OMERO.blitz] 504255     [l.Server-0]  
INFO   ome.services.blitz.util.IceMethodInvoker  - Handling:
2008/04/30 08:25 +0100 [-] [OMERO.blitz]  
ome.conditions.RemovedSessionException: No context for  
39d00213-3861-4d7a-95c1-33d432b100af
2008/04/30 08:25 +0100 [-] [OMERO.blitz]        at  
ome.services.sessions.state.SessionCache.getSessionContext 
(SessionCache.java:156)
2008/04/30 08:25 +0100 [-] [OMERO.blitz]        at  
ome.services.sessions.SessionManagerImpl.getUserRoles 
(SessionManagerImpl.java:302)
...
ERROR  ome.services.blitz.util.IceMethodInvoker  - RootException  
thrown which is an unknown subclasss.
2008/04/30 08:25 +0100 [-] [OMERO.blitz] This most likely means that  
an exception was added to the
2008/04/30 08:25 +0100 [-] [OMERO.blitz] ome.conditions hierarchy,  
without being accountd for in blitz:
2008/04/30 08:25 +0100 [-] [OMERO.blitz]  
ome.conditions.RemovedSessionException
2008/04/30 08:25 +0100 [-] [OMERO.blitz] 504257     [l.Server-0]  
ERROR   ome.services.blitz.impl.ServiceFactoryI  - Failure to close:  
39d00213-3861-4d7a-95c1-33d432b100af/9d:63:2a:56:2ce150d: 
1199e3135e7:-7ff9omero.api.RenderingEngine=omero.api._RenderingEngineTie 
@1f5f36a
2008/04/30 08:25 +0100 [-] [OMERO.blitz]  
java.lang.reflect.InvocationTargetException
...
2008/04/30 08:25 +0100 [-] [OMERO.blitz]        at  
omero.api._RenderingEngineTie.close(_RenderingEngineTie.java:350)
2008/04/30 08:25 +0100 [-] [OMERO.blitz]        ... 13 more
2008/04/30 08:25 +0100 [-] [OMERO.blitz] Caused by:  
omero.InternalException
2008/04/30 08:25 +0100 [-] [OMERO.blitz]     serverStackTrace =  
"ome.conditions.RemovedSessionException: No context for  
39d00213-3861-4d7a-95c1-33d432b100af
2008/04/30 08:25 +0100 [-]  
[OMERO.blitz]                                at  
ome.services.sessions.state.SessionCache.getSessionContext 
(SessionCache.java:156)
2008/04/30 08:25 +0100 [-]  
[OMERO.blitz]                                at  
ome.services.sessions.SessionManagerImpl.getUserRoles 
(SessionManagerImpl.java:302)

...


Thanks
Ola


comment:3 Changed 13 years ago by jmoore

  • Milestone changed from 3.0-Beta4 to 3.0-Beta3

r2392 adds the exceptions to the invoker to get rid of the "This most likely means that an exception was added to the" message. close() is still not fixed.

comment:4 Changed 13 years ago by jmoore

  • Status changed from new to assigned

comment:5 Changed 13 years ago by jmoore

  • Resolution set to fixed
  • Status changed from assigned to closed

r2397 should fix this. Closing. Please re-open if you see any other instances.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.62324 sec.)

We're Hiring!