Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9039 (closed)

Opened 10 years ago

Closed 9 years ago

Last modified 9 years ago

Bug: Share Delete/Remove toolbar

Reported by: wmoore Owned by: wmoore
Priority: critical Milestone: OMERO-4.4
Component: Web Version: n.a.
Keywords: n.a. Cc: bpindelski, ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-07-17 (19)

Description

If I create a new share and include 'root' user, then log in as root and select images in the Share tree, the "Delete" icon (bin) is activated, although the tooltip says "Remove".

When I click it I am asked to confirm, this gives me an alert of "NonType? object has no attribute _obj".

Not sure what functionality the Bin icon is trying to provide? Delete?

Found by Blazej

Change History (9)

comment:1 Changed 9 years ago by jburel

  • Sprint changed from 2012-06-05 (16) to 2012-06-19 (17)

Moved from sprint 2012-06-05 (16)

comment:2 Changed 9 years ago by jburel

  • Sprint changed from 2012-06-19 (17) to 2012-07-03 (18)

Moved from sprint 2012-06-19 (17)

comment:3 Changed 9 years ago by saloynton

  • Cc ux@… added
  • Priority changed from major to critical

comment:4 Changed 9 years ago by wmoore

  • Resolution set to fixed
  • Status changed from new to closed

This seems to be working now. The "Remove" icon is only enabled for the Share Owner and allows them to Remove images from a share.

One remaining issue: If you can remove all the images from a share, it would make sense to be able to delete the Share itself (cf. #8790).

Last edited 9 years ago by bpindelski (previous) (diff)

comment:5 Changed 9 years ago by bpindelski

  • Resolution fixed deleted
  • Status changed from closed to reopened

With build 107, on BP, still happens when I delete images from user-1's (group owner) share as user-6 (admin), i.e. I get the NonType? object has no attribute _obj error.

The secret to hitting this error is to be in a different group than the one from which the share was started. So user-1 is in private-1, starts a share, invites user-6. User-6 logs in but doesn't change the group to private-1 (so stays in a default group, e.g. read-annotate-1). User-6 goes to the Public tab and sees a share. Deleting anything from it causes the error. Switching to group private-1 allows for error-free deletion.

Last edited 9 years ago by bpindelski (previous) (diff)

comment:6 Changed 9 years ago by wmoore

  • Owner changed from atarkowska to wmoore
  • Status changed from reopened to accepted

comment:7 Changed 9 years ago by jburel

  • Sprint changed from 2012-07-03 (18) to 2012-07-17 (19)

Moved from sprint 2012-07-03 (18)

comment:8 Changed 9 years ago by wmoore

  • Resolution set to fixed
  • Status changed from accepted to closed

Hopefully fixed by only allowing Image Owners to remove images from share. https://github.com/aleksandra-tarkowska/openmicroscopy/commit/ab999c6e8fb244828fbeb8c495cd9a945a189396

However, I didn't reproduce what was described above locally, since I don't have those groups & users set up.

comment:9 Changed 9 years ago by bpindelski

Tested. Fixed.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.64330 sec.)

We're Hiring!