Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9074 (closed)

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

Bug: LIFF Import

Reported by: wmoore Owned by: mlinkert
Priority: critical Milestone: OMERO-4.4
Component: Bio-Formats Version: n.a.
Keywords: n.a. Cc: jburel, cxallan
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-06-19 (17)

Description

I just tried importing a LIFF file, using a new Insight, server & DB from develop (right after sprint16 merge).

File is LIF/chris/free edge 6.liff

java.lang.NullPointerException
	at ome.formats.model.ChannelData.fromObjectContainerStore(ChannelData.java:265)
	at ome.formats.model.ChannelProcessor.process(ChannelProcessor.java:455)
	at ome.formats.OMEROMetadataStoreClient.postProcess(OMEROMetadataStoreClient.java:2098)
	at ome.formats.importer.ImportLibrary.importMetadata(ImportLibrary.java:349)
	at ome.formats.importer.ImportLibrary.importImage(ImportLibrary.java:537)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.importImage(OMEROGateway.java:6253)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1247)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:86)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:55)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:113)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)

	at org.openmicroscopy.shoola.env.data.OMEROGateway.importImage(OMEROGateway.java:6301)
	at org.openmicroscopy.shoola.env.data.OmeroImageServiceImpl.importFile(OmeroImageServiceImpl.java:1247)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.importFile(ImagesImporter.java:86)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter.access$000(ImagesImporter.java:55)
	at org.openmicroscopy.shoola.env.data.views.calls.ImagesImporter$1.doCall(ImagesImporter.java:113)
	at org.openmicroscopy.shoola.env.data.views.BatchCall.doStep(BatchCall.java:144)
	at org.openmicroscopy.shoola.util.concur.tasks.CompositeTask.doStep(CompositeTask.java:226)
	at org.openmicroscopy.shoola.env.data.views.CompositeBatchCall.doStep(CompositeBatchCall.java:126)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.exec(ExecCommand.java:165)
	at org.openmicroscopy.shoola.util.concur.tasks.ExecCommand.run(ExecCommand.java:276)
	at org.openmicroscopy.shoola.util.concur.tasks.AsyncProcessor$Runner.run(AsyncProcessor.java:91)
	at java.lang.Thread.run(Thread.java:680)
Caused by: java.lang.NullPointerException
	at ome.formats.model.ChannelData.fromObjectContainerStore(ChannelData.java:265)
	at ome.formats.model.ChannelProcessor.process(ChannelProcessor.java:455)
	at ome.formats.OMEROMetadataStoreClient.postProcess(OMEROMetadataStoreClient.java:2098)
	at ome.formats.importer.ImportLibrary.importMetadata(ImportLibrary.java:349)
	at ome.formats.importer.ImportLibrary.importImage(ImportLibrary.java:537)
	at org.openmicroscopy.shoola.env.data.OMEROGateway.importImage(OMEROGateway.java:6253)
	... 11 more

Change History (2)

comment:1 Changed 9 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed

comment:2 Changed 9 years ago by wmoore

Working fine now. ;)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.69285 sec.)

We're Hiring!