Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9078 (closed)

Opened 12 years ago

Closed 12 years ago

Bug: env.PWD does not work on Win7

Reported by: jamoore Owned by: jamoore
Priority: minor Milestone: OMERO-4.4
Component: Deployment Version: n.a.
Keywords: n.a. Cc: bpindelski
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-06-19 (17)

Description

On Win7, build version results in an "UNKNOWN" value due to the use of ${env.PWD}.

See http://www.openmicroscopy.org/community/viewtopic.php?f=6&t=1163&p=4574#p4574

Change History (3)

comment:1 Changed 12 years ago by jmoore

  • Cc bpindelski added
  • Owner set to jmoore

Blazej is examining the proper value via:

<project default="t">
    <property environment="XYZ"/>
    <target name="t">
        <echo>${XYZ.PWD}</echo>
    </target>
</project>

comment:2 Changed 12 years ago by jmoore

Blazej confirmed that PWD does not work on Win7, but user.dir does.

comment:3 Changed 12 years ago by jmoore

  • Resolution set to fixed
  • Sprint set to 2012-06-19 (17)
  • Status changed from new to closed

Pushed fix to sprint17:

commit dad093b2193c02818b736d052f6851f66978ec96
Author: jmoore <josh@glencoesoftware.com>
Date:   Fri Jun 8 17:05:47 2012

    Use ${user.dir} rather than ${env.PWD} (Fix #9078)
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.64530 sec.)

We're Hiring!