Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9151 (closed)

Opened 9 years ago

Closed 9 years ago

Bug: Alignment of labels on the user and group edit dialogs

Reported by: saloynton Owned by: atarkowska
Priority: critical Milestone: OMERO-4.4
Component: Web Version: n.a.
Keywords: n.a. Cc: web-team@…, ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2012-06-19 (17)

Description

The current alignment of the form labels are not aligned the location of the asterisks on the fields are not in the correct location. (Two screenshots attached for user and group edit)

This ticket was discussed in web meeting 11th June
https://www.openmicroscopy.org/site/community/minutes/minigroup/webmeeting/2012/2012-06-11

It was suggested that the location of the asterisks be moved but this could cause more problems. Ola will put into place a revised version.

Attachments (2)

Screen shot 2012-06-11 at 17.24.08.png (45.3 KB) - added by saloynton 9 years ago.
Screen shot 2012-06-11 at 17.24.27.png (101.6 KB) - added by saloynton 9 years ago.

Download all attachments as: .zip

Change History (13)

Changed 9 years ago by saloynton

Changed 9 years ago by saloynton

comment:1 Changed 9 years ago by atarkowska

  • Sprint set to 2012-06-19 (17)

comment:2 Changed 9 years ago by atarkowska

  • Status changed from new to accepted

comment:3 Changed 9 years ago by atarkowska

  • Remaining Time set to 0.3

comment:4 Changed 9 years ago by atarkowska

All required labels marked with * will be converted to red font. That's the easiest way to not touch standard_form class. Otherwise it will affect entire application.

comment:5 Changed 9 years ago by atarkowska

  • Remaining Time changed from 0.3 to 0
  • Status changed from accepted to closed

comment:6 Changed 9 years ago by atarkowska

That was fixed across the application.

Please check the list of pages need retesting:

  • raising error on web and submitting feedback
  • create and edit experimenter in webadmin
  • create and edit group in webadmin
  • managing groups permissions by owner in webadmin
  • myaccount in webadmin
  • create share and discussion in webadmin
  • edit share in webadmin
Last edited 9 years ago by atarkowska (previous) (diff)

comment:7 Changed 9 years ago by saloynton

Ticket re-opened for the following issues - with using the red text this is not a conventional
technique to indicate a required field in the forms. The additional label is required in the following place
as already shown in edit user.

  • create and edit group in webadmin - requires the label "Fields marked in red are mandatory."
  • managing groups permissions by owner in webadmin - requires the label "Fields marked in red are mandatory." removal of the text "Fields marked with an asterisk (*) are mandatory."
  • myaccount in webadmin - requires the label "Fields marked in red are mandatory."
  • create share and discussion in webadmin - the form requires the label "Fields marked in red are mandatory."
  • edit share in webadmin - the form requires the label "Fields marked in red are mandatory."

comment:8 Changed 9 years ago by saloynton

  • Status changed from closed to reopened

comment:9 Changed 9 years ago by saloynton

  • Remaining Time 0 deleted

comment:10 Changed 9 years ago by atarkowska

  • Remaining Time set to 0.1

comment:11 Changed 9 years ago by atarkowska

  • Remaining Time changed from 0.1 to 0
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.68570 sec.)

We're Hiring!