Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9227 (closed)

Opened 12 years ago

Closed 12 years ago

Bug: Discrepancy in required fields in user settings

Reported by: saloynton Owned by: jburel
Priority: minor Milestone: OMERO-4.4
Component: Insight Version: n.a.
Keywords: n.a. Cc: ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2012-07-03 (18)

Description

Discrepancy between what is required in user settings on web and insight

If I go into insight and click on myself (top of hierarchy browser) and then look at the right panel "User settings", I see only one field with a required red star. If in web, I click on my user (top right) and go to "My settings", I see 4 fields that are marked red.

We will need the extra red star to indicate the required fields in insight. Jean-Marie I will need to confirm what the actual logic is for these fields to confirm if they are required fields.

Change History (10)

comment:1 Changed 12 years ago by jburel

As I mentioned while that section was reviewed few weeks ago, the only required field in the model is the login name. All the other fields are optional.
Insight follows the model, the web doesn't i.e. the fields marked as required are not required in the model.

comment:2 Changed 12 years ago by jmoore

J-M, do you mean in the schema or the DB? Scott, this is an issue that's certainly come up before. Any ideas you have on how we can teach users where certain data is required and where the defaults come from would be great. For reference, here's the 4.4.0 DB definition of what's required:

           Table "public.experimenter"
   Column    |          Type          | Modifiers 
-------------+------------------------+-----------
 id          | bigint                 | not null
 permissions | bigint                 | not null
 email       | character varying(255) | 
 firstname   | character varying(255) | not null
 institution | character varying(255) | 
 lastname    | character varying(255) | not null
 middlename  | character varying(255) | 
 omename     | character varying(255) | not null
 version     | integer                | 
 external_id | bigint                 | 

comment:3 Changed 12 years ago by jburel

by model I mean schema.

comment:4 Changed 12 years ago by jburel

I will mark the First and last name as required. Okay with that?

comment:5 Changed 12 years ago by saloynton

That seems fine Jean-Marie, this will also help the problem reported in the web where the user list was difficult to read because of no first/last name was entered.

  • Josh I am not 100% sure what you mean by teaching users where the defaults come? In using the red asterisk is the standard to show where certain data is required. The asterisk has not been feasible on the web but will still need to be changed. Informing users about where the defaults come from seems like additional information?

comment:6 Changed 12 years ago by jmoore

Scott, it's definitely a much bigger / longer-term discussion. Just wanted to bring it up here. Happy to discuss elsewhere.

comment:7 Changed 12 years ago by jburel

  • Remaining Time set to 0.15
  • Sprint set to 2012-07-03 (18)

comment:8 Changed 12 years ago by jburel

  • For new user, the following fields are required login, first and last name, password.
  • When creating a new group, the admin can add the owner at the same time, The owner can already exist so I have an issue. I will have to review that later on. I will ask for all credentials => owner will be a new user.

comment:9 Changed 12 years ago by saloynton

  • Tested and working as expected.
  • I have created a RFE in the usability tab in the testing google doc as you can miss a required field and add a group. This then requires the user to remove the group and then add in the required field.
  • Josh: I have also created a row in the usability tab in the testing google doc to ensure we can have the discussion about teach users where certain data is required and where the defaults come from and referenced back to this ticket so I can make sure it is brought up again for you when the document is reviewed after release.

comment:10 Changed 12 years ago by jburel

  • Remaining Time changed from 0.15 to 0
  • Resolution set to fixed
  • Status changed from new to closed

The issue is now fixed and reference in the g.doc.Closing

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.65804 sec.)

We're Hiring!