Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9237 (closed)

Opened 12 years ago

Closed 12 years ago

Bug: LockException on VM shutdown

Reported by: jamoore Owned by: cmacleod-x
Priority: minor Milestone: OMERO-4.4.1
Component: Deployment Version: n.a.
Keywords: n.a. Cc: cmacleod-x
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Accessing config.xml lead to a lockexception. See screenshot

Attachments (2)

ss-vm-LockExcepti.png (24.5 KB) - added by jmoore 12 years ago.
lock-exception.png (37.4 KB) - added by bpindelski 12 years ago.

Download all attachments as: .zip

Change History (13)

Changed 12 years ago by jmoore

comment:1 Changed 12 years ago by cmacleod-x

Not familiar with the lock exception but I'm assuming this is due to ordering upon shutdown. Have a recommendation on how to fix it?

comment:2 Changed 12 years ago by cmacleod-x

  • Owner set to cmacleod-x
  • Status changed from new to accepted

comment:3 Changed 12 years ago by cmacleod-x

Which VM version is this as well?

comment:4 Changed 12 years ago by cmacleod-x

  • Resolution set to worksforme
  • Status changed from accepted to closed

Unable to reproduce on 4.3.4 nor on a recent snapshot. Tested both an external shutdown by virtualbox as well as a shutdown from inside the OS.

comment:5 Changed 12 years ago by jmoore

Note: just started up the RC2 build and omero web wasn't running. On trying /etc/init.d/omero-web status I got this:

root@omerovm:/etc/init.d# /etc/init.d/omero-web status
Status omero-web:OMERO.web status... Traceback (most recent call last):
  File "/home/omero/OMERO.server/bin/omero", line 123, in <module>
    rv = omero.cli.argv()
  File "/home/omero/OMERO.server/lib/python/omero/cli.py", line 1184, in argv
    cli.invoke(args[1:])
  File "/home/omero/OMERO.server/lib/python/omero/cli.py", line 734, in invoke
    stop = self.onecmd(line, previous_args)
  File "/home/omero/OMERO.server/lib/python/omero/cli.py", line 803, in onecmd
    self.execute(line, previous_args)
  File "/home/omero/OMERO.server/lib/python/omero/cli.py", line 883, in execute
    args.func(args)
  File "/home/omero/OMERO.server/lib/python/omero/plugins/web.py", line 365, in status
    import omeroweb.settings as settings
  File "/home/omero/OMERO.server/lib/python/omeroweb/settings.py", line 156, in <module>
    raise exctype, value
portalocker.LockException: (1, 'Resource temporarily unavailable')

comment:6 Changed 12 years ago by bpindelski

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Changed 12 years ago by bpindelski

comment:7 Changed 12 years ago by bpindelski

Reopening. Another type of lock exception happening now... Would be maybe good to add some timeout logic in the shutdown script? Added lock-exception.png

comment:8 Changed 12 years ago by cmacleod-x

What memory settings are configured on the VM, also what version of virtualbox?

comment:9 Changed 12 years ago by bpindelski

It's the VM from build #399. 1024 MB of RAM. VirtualBox? 4.1.18 on OS X 10.6.8.

comment:10 Changed 12 years ago by jmoore

  • Milestone changed from OMERO-4.4 to OMERO-4.4.1

Nothing we can do about it in 4.4.0

comment:11 Changed 12 years ago by cmacleod-x

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed in https://github.com/stick/openmicroscopy/commit/53846469e0109926e2456da54e22276949fdb6e2
Looks like it was a race condition between an existing session and when postgres was shutdown. I've fixed the deps in the initscripts to do things in a more correct order. Debian's boot process runs all scripts of the same level concurrently so the race condition was exasperated.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.86848 sec.)

We're Hiring!