Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9273 (closed)

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

Bug: Import of images with numeric file names

Reported by: cblackburn Owned by: mlinkert
Priority: major Milestone: OMERO-4.4
Component: Import Version: n.a.
Keywords: n.a. Cc: jburel, mlinkert, jamoore, cxallan
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-07-17 (19)

Description

See: https://www.openmicroscopy.org/community/viewtopic.php?f=4&t=1222

It looks like files with names consisting solely of numerals are failing to import when using a Windows client. I have not yet investigated further to discover if this is an Insight or bio-formats problem.

Change History (8)

comment:1 Changed 10 years ago by jmoore

  • Milestone changed from Unscheduled to OMERO-Beta4.4

Just moving to 4.4 so it gets at least one good looking at.

comment:2 Changed 10 years ago by mlinkert

Colin, could you please put the files in question up somewhere where I can take a look at them? I wasn't able to reproduce the problem in a simple test of copying a TIFF from test_images_good to files named A1.tiff and 1.tiff.

Usually "File Not Valid" means that the file is empty, so it would be worth checking that the MD5s match and that 1.tiff actually contains data.

comment:3 Changed 10 years ago by cblackburn

Melissa, the files are on squig under team/ForMelissa/MLB tiffs . I did an md5 and the files were identical. I also spent some time renaming and trying to import files. So, for instance, 1.tif, 2.tif and 12345.tif all failed. A1.tif and 2A.tif imported. There is no problem, as far as I can see on a Mac. This problem is only using Insight on Windows (gre-mporter) both 4.3.3 and 4.4 RC1. I have not tested against a Linux client and I haven't tested cli import on any platform.

comment:4 Changed 10 years ago by mlinkert

  • Component changed from General to Import
  • Owner set to mlinkert-x
  • Sprint set to 2012-07-17 (19)

Thanks Colin. The problem does indeed only occur on Windows, and I think it's due to an incorrect file name comparison in the parse(...) method of the Groups class in ImportCandidates?.java. I don't know yet if the root cause is in Bio-Formats (it could well be), but I'll investigate further later today.

comment:5 Changed 10 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 10 years ago by mlinkert

  • Resolution fixed deleted
  • Status changed from closed to reopened

It works for just 1.tif and A1.tif, but if we copy 1.tif to 2.tif then both 1.tif and 2.tif fail to import.

comment:7 Changed 10 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:8 Changed 10 years ago by rleigh

Tested OK for me on gre-mporter.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.81840 sec.)

We're Hiring!