Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9423 (closed)

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

Bug: Right hand panel and scroll bar

Reported by: saloynton Owned by: sylittlewood
Priority: minor Milestone: OMERO-4.4.4
Component: Insight Version: n.a.
Keywords: n.a. Cc: ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-08-14 (2)

Description

Reading the information in the right hand panel is more difficult to do with the way the scroll bar is set at the default.

Change History (6)

comment:1 Changed 9 years ago by sylittlewood

  • Status changed from new to accepted

comment:2 Changed 9 years ago by sylittlewood

Investigating the cause of this issue using SpringExplorer? to inspect the UI.

  • TreeViewerWin?/JRootPane/JLayeredPane/JPanel/JSplitPane/JSplitPane/JScrollPane/JViewport - width 719
  • TreeViewerWin?/JRootPane/JLayeredPane/JPanel/JSplitPane/JSplitPane/JScrollPane/JViewport/EditorUI - width 750

comment:3 Changed 9 years ago by sylittlewood

  • Sprint set to 2012-08-14 (2)

comment:4 Changed 9 years ago by sylittlewood

setExtentWidth() in PropertiesUI is the cause of this issue. Lots of complex width calculations here, need to diagnose what they are doing.

comment:5 Changed 9 years ago by sylittlewood

  • Resolution set to fixed
  • Status changed from accepted to closed

Resolved temporarily by removing code around calculating the width for scrollable description text. The infinite scroll issue is resolved but now description text will not wrap. Will need to investigate this later.

comment:6 Changed 9 years ago by Scott Littlewood <scottlittlewood@…>

(In [be1f49d732f188e9a891cb5e19eb4e9f3e8fc8f6/ome.git] on branch develop) Remove code around resizing the description field, see #9423

Now it won't wrap but the scrolling issue won't occur, will need to address the flow and resizing of the description box.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.65261 sec.)

We're Hiring!