Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9614 (closed)

Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

Bug: Image count in Share

Reported by: bpindelski Owned by: wmoore
Priority: major Milestone: OMERO-4.4.7
Component: Web Version: n.a.
Keywords: n.a. Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2012-10-23 (1)

Description

After creating a share in Web, the reported image count is wrong. See attached image.

Attachments (1)

share-count.png (103.1 KB) - added by bpindelski 12 years ago.

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by bpindelski

comment:1 Changed 12 years ago by wmoore

  • Sprint set to 2012-10-23 (1)

comment:3 Changed 12 years ago by wmoore

  • Resolution set to fixed
  • Status changed from new to closed

comment:4 Changed 11 years ago by Will Moore <will@…>

(In [c93d9bb93887fdbce203372828e370126fe93b71/ome.git] on branch develop) Removing addObjects() from share creation. See #9614

This statement seems responsilble to adding omero.model.FormatI objects to the share
as retrieved by shareService.getContents(sid). These add to the content count but are
not displayed in web because we filter for images only.
According to Josh, the addObjects() method is old and should not be needed anymore but
'no promises - needs testing'.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.66896 sec.)

We're Hiring!