Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9808 (closed)

Opened 12 years ago

Closed 12 years ago

BUG:Qa4653 - ArrayIndexOutOfBounds on int32

Reported by: omero-qa Owned by: mlinkert
Priority: minor Milestone: OMERO-4.4.7
Component: from QA Version: n.a.
Keywords: n.a. Cc: dennis@…, jamoore, jburel
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

https://www.openmicroscopy.org/qa2/qa/feedback/4653/

Comment: The importer is not creating thumbnails. This error maybe related to that. This thumbnail issue does not appear to be the same at the one in the forums. Might be due to a latency issue.

("error in call","Traceback (most recent call last):
  File "/usr/omero/lib/python/omeroweb/webgateway/views.py", line 1013, in wrap
    rv = f(request, *args, **kwargs)
  File "/usr/omero/lib/python/omeroweb/webgateway/views.py", line 1121, in imageData_json
    rv = imageMarshal(image, key)
  File "/usr/omero/lib/python/omeroweb/webgateway/marshal.py", line 96, in imageMarshal
    reOK = image._prepareRenderingEngine()
  File "/usr/omero/lib/python/omero/gateway/__init__.py", line 5702, in _prepareRenderingEngine
    self._re = self._prepareRE(rdid=rdid)
  File "/usr/omero/lib/python/omero/gateway/__init__.py", line 5683, in _prepareRE
    re.load(ctx)
  File "/usr/omero/lib/python/omero/gateway/__init__.py", line 3327, in __call__
    return self.handle_exception(e, *args, **kwargs)
  File "/usr/omero/lib/python/omeroweb/webclient/webclient_gateway.py", line 1875, in handle_exception
    super(OmeroWebSafeCallWrapper, self).handle_exception(
  File "/usr/omero/lib/python/omero/gateway/__init__.py", line 3324, in __call__
    return self.f(*args, **kwargs)
  File "/usr/omero/lib/python/omero_api_RenderingEngine_ice.py", line 410, in load
    return _M_omero.api.RenderingEngine._op_load.invoke(self, ((), _ctx))
InternalException: exception ::omero::InternalException
{
    serverStackTrace = ome.conditions.InternalException:  Wrapped Exception: (java.lang.ArrayIndexOutOfBoundsException):
null

    serverExceptionClass = ome.conditions.InternalException
    message =  Wrapped Exception: (java.lang.ArrayIndexOutOfBoundsException):
null
}
")

Change History (3)

comment:1 Changed 12 years ago by jmoore

  • Cc jmoore added
  • Milestone changed from Unscheduled to OMERO-4.5

Melissa, something went wrong when initially assigning this QA to a ticket, so it's gone unnoticed for some time. Perhaps the issue's already been corrected?

comment:2 Changed 12 years ago by jmoore

  • Cc jburel added

Also adding J-M since it's (only?) a rendering issue.

comment:3 Changed 12 years ago by mlinkert

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #9731.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.72879 sec.)

We're Hiring!