Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9922 (closed)

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

BUG: Error - Delete wells in Screen in Web

Reported by: pwalczysko Owned by: wmoore
Priority: critical Milestone: OMERO-4.4.7
Component: Web Version: n.a.
Keywords: Screen, plate, delete Cc: jburel
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: 2013-03-12 (6))

Description

Worked originally in IE8 Win XP, but because the Dtacktrace there is invisible, reproduced the bug in Safari Mac 10.8.
logged in as petr on Howe.
The Screen opened and 2 wells chosen and Deleted.
Another well chosen, basket icon pressed.
The ensuing delete window was cancelled.
A well was selected (as thumbnail).

Error 500 appeared.
After cancelling the error window, another thumbnail/well was selected.
Another error 500 appeared.
Logged out and checked the plate in Insight.
The plate was empty (all 16 wells gone).

Traceback (most recent call last):

  File "/home/hudson/hudson/workspace/OMERO-merge-4.4/src/dist/lib/python/django/core/handlers/base.py", line 111, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/home/hudson/hudson/workspace/OMERO-merge-4.4/src/dist/lib/python/omeroweb/decorators.py", line 377, in wrapped
    retval = f(request, *args, **kwargs)

  File "/home/hudson/hudson/workspace/OMERO-merge-4.4/src/dist/lib/python/omeroweb/decorators.py", line 414, in wrapper
    context = f(request, *args, **kwargs)

  File "/home/hudson/hudson/workspace/OMERO-merge-4.4/src/dist/lib/python/omeroweb/webclient/views.py", line 1088, in batch_annotate
    batchAnns = manager.loadBatchAnnotations(objs)

  File "/home/hudson/hudson/workspace/OMERO-merge-4.4/src/dist/lib/python/omeroweb/webclient/controller/container.py", line 429, in loadBatchAnnotations
    parent_ids[i] = o.getWellSample().image().getId() # index has already been set

AttributeError: 'NoneType' object has no attribute 'image'


<WSGIRequest
GET:<QueryDict: {u'well': [u'4884', u'4886']}>,
POST:<QueryDict: {}>,
COOKIES:{'sessionid': '8f68991526793d02cb7e896e6624b41a'},
META:{'DOCUMENT_ROOT': '/var/www',
 'GATEWAY_INTERFACE': 'CGI/1.1',
 'HTTP_ACCEPT': 'text/html, */*; q=0.01',
 'HTTP_ACCEPT_ENCODING': 'gzip, deflate',
 'HTTP_ACCEPT_LANGUAGE': 'en-us',
 'HTTP_CONNECTION': 'keep-alive',
 'HTTP_COOKIE': 'sessionid=8f68991526793d02cb7e896e6624b41a',
 'HTTP_HOST': 'howe.openmicroscopy.org.uk',
 'HTTP_REFERER': 'http://howe.openmicroscopy.org.uk/webclient/',
 'HTTP_USER_AGENT': 'Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/536.26.14 (KHTML, like Gecko) Version/6.0.1 Safari/536.26.14',
 'HTTP_X_REQUESTED_WITH': 'XMLHttpRequest',
 'PATH': '/usr/local/bin:/usr/bin:/bin',
 'PATH_INFO': u'/webclient/batch_annotate/',
 'PATH_TRANSLATED': '/var/www/omero.fcgi/webclient/batch_annotate/',
 'QUERY_STRING': 'well=4884&well=4886',
 'REMOTE_ADDR': '10.12.2.209',
 'REMOTE_PORT': '61714',
 'REQUEST_METHOD': 'GET',
 'REQUEST_URI': '/webclient/batch_annotate/?well=4884&well=4886',
 'SCRIPT_FILENAME': '/var/www/omero.fcgi',
 'SCRIPT_NAME': u'',
 'SERVER_ADDR': '134.36.65.228',
 'SERVER_ADMIN': 'webmaster@localhost',
 'SERVER_NAME': 'howe.openmicroscopy.org.uk',
 'SERVER_PORT': '80',
 'SERVER_PROTOCOL': 'HTTP/1.1',
 'SERVER_SIGNATURE': '<address>Apache/2.2.14 (Ubuntu) Server at howe.openmicroscopy.org.uk Port 80</address>\n',
 'SERVER_SOFTWARE': 'Apache/2.2.14 (Ubuntu)',
 'wsgi.errors': <flup.server.fcgi_base.TeeOutputStream object at 0x36e4350>,
 'wsgi.input': <flup.server.fcgi_base.InputStream object at 0x36e5a50>,
 'wsgi.multiprocess': True,
 'wsgi.multithread': False,
 'wsgi.run_once': False,
 'wsgi.url_scheme': 'http',
 'wsgi.version': (1, 0)}>

Change History (10)

comment:1 Changed 11 years ago by pwalczysko

[[Although I understand now that this is actually MEANT to delete the whole Acquisition/Run?, I still think that the user should be massively warned before going ahead with the action. This is true for Web as well as Insight. Web has the additional unfortunate complication that the UI is pretending like if it has really deleted just the selected wells for a while before a server error appears.

The non-unified naming (in the tree in Web the entity is called "Plate", whereas in the Web the warning window before the Delete action speaks about "Acquisition") does not help at all.]]

comment:2 Changed 11 years ago by pwalczysko

comment:3 Changed 11 years ago by wmoore

  • Sprint changed from 2012-11-20 (2) to 2012-12-18 (3)

We don't currently support the deletion of wells. We need to disable the Delete button in toolbar when a well is selected.

comment:4 Changed 11 years ago by wmoore

  • Owner changed from web-team@… to wmoore

comment:5 Changed 11 years ago by pwalczysko

Yes, I fully agree, the button should be disabled in these cases. The reason for the "critical" rating of the ticket is that this sequence of coincidences/bugs/misunderstandings has the potential of inadvertent loss of data' for the user, which I think should be prevented in first place (it actually did cause a loss of data for me during the testing).

comment:6 Changed 11 years ago by jburel

  • Sprint changed from 2012-12-18 (3) to 2013-01-15 (4)

Moved from sprint 2012-12-18 (3)

comment:7 Changed 11 years ago by jburel

  • Sprint changed from 2013-01-15 (4) to 2013-02-12 (5)

Moved from sprint 2013-01-15 (4)

comment:8 Changed 11 years ago by jburel

  • Sprint changed from 2013-02-12 (5) to 2013-03-12 (6))

Moved from sprint 2013-02-12 (5)

comment:9 Changed 11 years ago by wmoore

  • Resolution set to fixed
  • Status changed from new to closed

comment:10 Changed 11 years ago by Will Moore <will@…>

(In [f5680f017ac9a130c801eae10f01630e97eb21d9/ome.git] on branch develop) Fix toolbar buttons disabled on Well selection. See #9922

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.65703 sec.)

We're Hiring!