Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9925 (closed)

Opened 8 years ago

Closed 7 years ago

Last modified 7 years ago

BUG : ROI Intensity Results View Add Selected button not working

Reported by: pwalczysko Owned by: mtbcarroll
Priority: major Milestone: 5.0.0-rc1
Component: Insight Version: 4.4.9
Keywords: FS Cc: ux@…, fs@…, mtbcarroll
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: OMERO 5 Beta 2 (1)

Description (last modified by pwalczysko)

Re-opening this ticket for FS. The problem is very similar there. The workflow was fixed in dev_4_4.

Old description was:
Created ROIs. Went to Intensity Results View tab.
Although the created ROI is obviously selected in the image, when the Add Selected button is pressed, no values are added to the table (the action was obviously ignored, as the message at the bottom of the window says "Ready" and not "Analysing...".).
To get the Add selected button working, you have to either:

-1. press Remove All button (although nothing is present in the table) and then press "Add selected" again

  • 2 or deselect the region in the image, select another one, go to the original region, select and press Add selected
  • 3. or be on the Intensity Results View tab in the moment of creation of the region - then the Add selected button reacts immediately

It does not help to remove the bug if:

  • you just deselect and select again the original region (for this reason this ticket was upgraded to major) - the bug is still there - you have to select ANOTHER region first in order to get the button working (see point 2. above)

If the scenario under 3. above is tried, it is enough to navigate to another tab of the ROI Tools window ("Manager" for example), then come back to the Intensity Results View tab

(the region is still selected - all the time since it was created )

  • press Add selected button now - the bug is back

Attachments (1)

Add selected does not work 1st time.png (639.6 KB) - added by pwalczysko 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by pwalczysko

comment:1 Changed 8 years ago by pwalczysko

  • Description modified (diff)
  • Priority changed from minor to major

comment:2 Changed 8 years ago by jburel

  • Sprint changed from 2012-11-20 (2) to 2012-12-18 (3)

Moved from sprint 2012-11-20 (2)

comment:3 Changed 8 years ago by mtbcarroll

  • Owner changed from jburel to mtbcarroll
  • Status changed from new to accepted

comment:4 Changed 8 years ago by mtbcarroll

Mmm, it's interesting. If you go straight to the Intensity Results View, the bug doesn't happen. If you look at the Intensity View first, then go to the Intensity Results View, the bug is there.

comment:6 Changed 8 years ago by jburel

  • Resolution set to fixed
  • Status changed from accepted to closed

The PR has been merged. Closing

comment:7 Changed 7 years ago by pwalczysko

Reopening the bug, although the build is now develop (FS) - the original was reported for dev_4_4 and the behaviour is slightly different. Nevertheless, the tab in ROI tool is the same, and the problem demonstrates itself very similarly.

Workflow:

  • today's build on Gretzky
  • user-4
  • import dv folder
  • pick an image (multi-z) and
  • create couple of line and rectangle regions
  • select a rectangular region not being on the Intensity Results View tab
  • navigate to Intensity Restults View tab and
  • click the "Add Selecetd" button
  • nothing happens (expected behaviour is for the values of the selected region to be added)


Alternative workflow:

  • deselect the region and navigate to Intensity Results View tab
  • select the region being on this tab
  • click "Add selected" - nothing happens

The only way how to make the "Add selected" button work is:

  • press the "Remove All" button (although nothing is there to remove)
  • press the "Add selected" button now (the region is still selected of course)
  • the values appear in the table as expected

comment:8 Changed 7 years ago by pwalczysko

  • Cc fs@… mtbcarroll added
  • Description modified (diff)
  • Keywords FS added
  • Milestone changed from OMERO-4.4.7 to OMERO-5
  • Resolution fixed deleted
  • Sprint changed from 2012-12-18 (3) to FS demo 4.x
  • Status changed from closed to reopened

comment:9 Changed 7 years ago by jburel

  • Milestone changed from 5.0.0 to 5.0.0-beta2
  • Resolution set to fixed
  • Sprint changed from FS demo 4.x to OMERO 5 Beta 2 (1)
  • Status changed from reopened to closed
  • Version set to 4.4.9

comment:10 Changed 7 years ago by Jean-Marie Burel <j.burel@…>

(In [fe68212398f28905bc1c6a923347a2b9b5b24edd/ome.git] on branch develop) Fix add of roi to results table (see #9925)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.140939 sec.)

We're Hiring!