Warning: Can't synchronize with repository "(default)" (/home/git/ome.git does not appear to be a Git repository.). Look in the Trac log for more information.
Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9931 (closed)

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

Movie Figure

Reported by: omero-qa Owned by: jburel
Priority: major Milestone: OMERO-4.4.7
Component: Scripting Version: n.a.
Keywords: n.a. Cc: a.ostrowski@…, ux@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: 2012-12-18 (3)

Description

https://www.openmicroscopy.org/qa2/qa2/qa/feedback/4751/

Comment: Hi,

While making a Movie Figure the Images per Row option doesn't work, i.e. whatever the setting is you end up with a single row of images. The selection between seconds, minutes etc. doesn't work either and you end up with seconds every time.

Cheers,
Adam.


    

Attachments (3)

9931_step1.png (584.1 KB) - added by jburel 9 years ago.
9931_step2.png (67.0 KB) - added by jburel 9 years ago.
Attachments get the same name.png (10.9 KB) - added by pwalczysko 9 years ago.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 9 years ago by wmoore

  • Component changed from from QA to Scripting
  • Milestone changed from Unscheduled to OMERO-4.5
  • Owner changed from wmoore to jburel
  • Priority changed from minor to major
  • Sprint set to 2012-12-18 (3)

Script fixes in https://github.com/ome/scripts/pull/12

JM - I'm not seeing any values for Max_Columns passed to the script. In fact - up until now the script didn't support this parameter (only the Movie_ROI_Figure did). So maybe it's being passed to the script as a differently named parameter?

comment:2 Changed 9 years ago by jburel

  • Remaining Time set to 0.2
  • Status changed from new to accepted

comment:3 Changed 9 years ago by jburel

To test:

  • Select an image with several timepoints
  • Select the movie figure script from the customized Ui menu. see screenshot step1
  • Modify the Image per row value, default is 10, set it to 3 for example.
  • Run the script. When completed, open the image created (e.g. png file) and check that the number per row matches the value entered.

comment:4 Changed 9 years ago by jburel

  • Cc ux@… added; jburel removed

Changed 9 years ago by jburel

Changed 9 years ago by jburel

comment:5 Changed 9 years ago by jburel

  • Remaining Time changed from 0.2 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed

comment:6 Changed 9 years ago by pwalczysko

Build OMERO.insight-4.4.5-113-696d61c-dirty-ice33-b69-mac. Also tried the one from "package" folder with identical results.\
Logged in as user-2, project sample_images, image 2ch ZT.lsm.
After the movie figure script was run with "images per row" to any value (10, 5, 1, 2), the result is always the same - in the created .png the images are arranged
in 1 single row only.

comment:7 Changed 9 years ago by pwalczysko

I think the script works as expected (if the result is viewed by clicking on link in Activities window and choosing View), but the results get ruined by the attachments handling in Insight.

Should I create a new ticket for it ?

The issue is this:
Run the script 2 times on the same image, each time with different number of images per row (e.g. 10 images per row the first time, 2 images per row the second time)
when you click on the blue link in Activities window and choose View then everything seems all right (first time 10 images, second time 2 images are in the row)

BUT IF YOU DO NOT GO to VIEW in ACTIVITIES Window:
when you click on the blue link in Activities and choose Go to Attachment (Do not View it first !), the second time when you ran the script a new (second) attachment will be created, with THE SAME NAME (see screenshot) and the same .png in it as the first time = you will get two identical attachments, with 10 images per row each (the first run overrules all the newcomer attachments).
If you ignore the activities window and go straight to the attachments, the result is the same - not satisfactory - the new attachment has 10 images per row.
If you delete all the attachments and try to go "from scratch" again and run the script again - all the new atatchments will have 10 images per row.

This means that the user can never change his mind about how many images he puts in the row - every consecutive attachment will have 10 images per row.

Version 0, edited 9 years ago by pwalczysko (next)

Changed 9 years ago by pwalczysko

comment:8 Changed 9 years ago by jburel <j.burel@…>

(In [fee5f7f596eafad364666a8ff95cacff0a0ef81a/ome.git] on branch develop) Pass max per columns to figure scripts (see #9931)

comment:9 Changed 9 years ago by jean-marie burel <j.burel@…>

(In [eadc783a3531bba4fef2743ce88087d2d88f5825/ome.git] on branch develop) Merge pull request #505 from jburel/figure-bugs-develop

Pass max per columns to figure scripts (see #9931)

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.90780 sec.)

We're Hiring!