Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #9971 (closed)

Opened 8 years ago

Closed 7 years ago

Bug: OMERO.tables string columns are silently truncated

Reported by: spli Owned by: spli
Priority: major Milestone: OMERO-4.4.7
Component: API Version: n.a.
Keywords: n.a. Cc: analysis@…
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: 0.0d
Sprint: Bugs Fixing

Description (last modified by spli)

String columns in OMERO.Tables have a width that is defined when the table is initialised. If a string longer than than this width is inserted it is silently truncated.

Also, the column width defaults to 1 if nothing/0 is specified at initialisation.

Fixes to either of these could be considered (undocumented) API changes. The first should be uncontroversial, the latter I consider a bug too: I think the main reason a user would omit the width is if they thought StringColumns? could hold strings of any length, whereas the current implementation creates a column of width 1 and silently truncates added data. It's unclear whether #1716 was intended to work around only uninitialised columns, or to deliberately default to size 1.

Change History (9)

comment:1 Changed 8 years ago by spli

  • Component changed from General to API
  • Milestone set to Unscheduled
  • Summary changed from OMERO.tables string columns are silently truncated to Bug: OMERO.tables string columns are silently truncated
  • Type changed from Bug to Task

comment:2 Changed 8 years ago by spli

  • Cc analysis@… added

comment:3 Changed 8 years ago by spli

  • Milestone changed from Unscheduled to OMERO-4.5
  • Remaining Time set to 0.5
  • Sprint set to 2012-12-18 (3)
  • Status changed from new to accepted

comment:4 Changed 8 years ago by spli

  • Description modified (diff)
  • Priority changed from minor to major

comment:5 Changed 8 years ago by jburel

  • Sprint changed from 2012-12-18 (3) to 2013-01-15 (4)

Moved from sprint 2012-12-18 (3)

comment:6 Changed 8 years ago by jburel

  • Sprint changed from 2013-01-15 (4) to 2013-02-12 (5)

Moved from sprint 2013-01-15 (4)

comment:7 Changed 7 years ago by jburel

  • Sprint changed from 2013-02-12 (5) to 2013-03-12 (6))

Moved from sprint 2013-02-12 (5)

comment:8 Changed 7 years ago by jburel

  • Sprint changed from 2013-03-12 (6)) to Bugs Fixing

comment:9 Changed 7 years ago by spli

  • Remaining Time changed from 0.5 to 0
  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.202741 sec.)

We're Hiring!