Notice: In order to edit this ticket you need to be either: a Product Owner, The owner or the reporter of the ticket, or, in case of a Task not yet assigned, a team_member"

Task #12732 (closed)

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

Bug: bfconvert writes invalid OME-XML containing MetadataOnly

Reported by: rleigh Owned by: mlinkert
Priority: major Milestone: 5.1.0
Component: Bio-Formats Version: 5.0.8
Keywords: OMETiffWriter Cc:
Resources: n.a. Referenced By: n.a.
References: n.a. Remaining Time: n.a.
Sprint: n.a.

Description

Reproducible with 5.0.8:

tools/bfconvert Beta\ Catenin.lif BetaCatenin.ome.tiff
./tools/tiffcomment BetaCatenin.ome.tiff > xml
./tools/xmlvalid xml 
Parsing schema path
http://www.openmicroscopy.org/Schemas/OME/2013-06/ome.xsd
Validating xml
cvc-complex-type.2.4.a: Invalid content was found starting with element 'MetadataOnly'. One of '{"http://www.openmicroscopy.org/Schemas/OME/2013-06":TiffData, "http://www.openmicroscopy.org/Schemas/OME/2013-06":Plane, "http://www.openmicroscopy.org/Schemas/SA/2013-06":AnnotationRef}' is expected.
cvc-complex-type.2.4.a: Invalid content was found starting with element 'MetadataOnly'. One of '{"http://www.openmicroscopy.org/Schemas/OME/2013-06":TiffData, "http://www.openmicroscopy.org/Schemas/OME/2013-06":Plane, "http://www.openmicroscopy.org/Schemas/SA/2013-06":AnnotationRef}' is expected.
cvc-complex-type.2.4.a: Invalid content was found starting with element 'MetadataOnly'. One of '{"http://www.openmicroscopy.org/Schemas/OME/2013-06":TiffData, "http://www.openmicroscopy.org/Schemas/OME/2013-06":Plane, "http://www.openmicroscopy.org/Schemas/SA/2013-06":AnnotationRef}' is expected.
cvc-complex-type.2.4.a: Invalid content was found starting with element 'MetadataOnly'. One of '{"http://www.openmicroscopy.org/Schemas/OME/2013-06":TiffData, "http://www.openmicroscopy.org/Schemas/OME/2013-06":Plane, "http://www.openmicroscopy.org/Schemas/SA/2013-06":AnnotationRef}' is expected.
cvc-complex-type.2.4.a: Invalid content was found starting with element 'MetadataOnly'. One of '{"http://www.openmicroscopy.org/Schemas/OME/2013-06":TiffData, "http://www.openmicroscopy.org/Schemas/OME/2013-06":Plane, "http://www.openmicroscopy.org/Schemas/SA/2013-06":AnnotationRef}' is expected.

Note that the showinf -omexml does validate, but it's validating the OME-XML after we've converted it and mangled it; it's not validating the original OME-XML which it silently accepts without warning.

Change History (5)

comment:1 Changed 6 years ago by mlinkert

  • Milestone changed from Unscheduled to 5.1.0

comment:2 Changed 6 years ago by mlinkert

  • Resolution set to fixed
  • Status changed from new to closed

I can reproduce as well with the v5.0.8 tag, but the same test on develop results in valid XML with no MetadataOnly?.

comment:3 Changed 6 years ago by rleigh

Is this something we want to backport? Should we treat the creation of invalid OME-XML as a serious problem given the interoperability issues it could cause?

comment:4 Changed 6 years ago by mlinkert

Likely not worth backporting unless a 5.0.9 is planned imminently. I don't think this is a particularly serious problem, as actually reading the exported files should be unaffected.

comment:5 Changed 6 years ago by rleigh

It's certainly not an issue with the Java OME-TIFF reader, since it silently ignores the problem when processing the data. But from the POV of an external consumer of OME-XML, we're writing out invalid nonconforming data.

Note: See TracTickets for help on using tickets. You may also have a look at Agilo extensions to the ticket.

1.3.13-PRO © 2008-2011 Agilo Software all rights reserved (this page was served in: 0.141237 sec.)

We're Hiring!